Welcome Guest 
技術士総監受験対策
picoメニュー
ブログカテゴリ一覧
amazon

総監フォーラム トピック一覧 since 2009/03/04

D3ブログ - Xoopsの不具合

Xoopsの不具合

カテゴリ : 
パソコン・ネット環境
執筆 : 
pmp_admin 2015-1-8 17:20
.

============================================================================

■技術士 総合技術監理部門 受験対策

●「総監虎の巻2015」 <対策本 pdfファイルで配信します>
 口頭試験対策本(4月発刊予定)を除き、最終稿ができました
 お待たせしました!!
 総監虎の巻2015の紹介は
   http://pmpstar.net/books/soukan_toranomaki2015_annnai.pdf
 申し込みエクセルファイルは
   http://pmpstar.net/books/soukan_books2015.xls
 申込先は
   soukan_books2015@@pmpstar.net (@を半角1文字にしてください)

●「総監虎の穴2015」 <対策講座>
 2015年度の総監講座の計画もほぼできました
   http://pmpstar.net/kouza/soukan_kouza2015_annnai.pdf
 申し込みエクセルファイルは
   http://pmpstar.net/kouza/soukan_kouza2015.xls
 申込先は
    soukan_kouza2015@@pmpstar.net (@を半角1文字にしてください)
 メニューを増やし、選択肢のある柔軟な講座を考えています
 従来通り、各講座人数限定ですので、申し込み順、入金順とさせていただきます

============================================================================

●Xoopsの不具合

ブログやコンテンツの日本語入力が出来なきなっている。
いつからか?
過去のブログの検証から2013/5/19まではフォント調整などできたようだ。

それ以降、ネット検索などで対処法を探していたが、
フォント調整なしで入力できるのでだましだまし、使ってきた。

しばらくして、画面に不明なコメントが発生するようになってきた。
ウィルスか? ハッキングされているのか?

ネット検索でXoopsに関し詳しい方のページを見つけたので質問を出してみた。

============================================================================

●質問内容

XOOPS Cube2.1(*) で使用しています。

●サーバーのハード・ソフトウェア情報

CPU Intel Xeon CPU E5-2670 0 @ 2.60GHz
MemTotal 8238MB
Apache 2.2
Perl 5.8.8
PHP 5.3.28(*)
RUBY 1.8.5
MySQL 5.1.73
PostgreSQL 8.2.23
Python 2.7.5
SQLite3 3.8.0.2
SQLite 2.8.17

●モジュールはここ2年ほどバージョンアップしていません。

●最近のトラブル
1.日本語入力
  ・ブログ は D3ブログを使用していますが従来できていた入力が できなくなりました。
  ・他の日本語入力でも同様です。
  ・使用エディタはFCKeditorを使用していましたが、現在xoopsデフォルトを使用しています。

2.ログインすると下記のコメントが発生するようになりました。
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacy/preload/InstallerChecker.class.php line 32
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacy/preload/ThemeSelect.class.php line 32
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacyRender/preload/Cacheclear.class.php line 26
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacyRender/preload/Cacheclear.class.php line 29
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/pm/preload/Preload.class.php line 10
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/pm/preload/Preload.class.php line 36
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/pm/preload/Preload.class.php line 61
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/pm/preload/Preload.class.php line 86
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file /virtual/pmp/xoops_trust_path/wizin/src/stdclass/Php52x.class.php line 39
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file /virtual/pmp/xoops_trust_path/modules/wizxc/class/WizXc_Util.class.php line 99
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file kernel/member.php line 79
ブログでは以下省略

色々調べましたが、対処法が判りません。
この解決にご指導をお願いいたしたく、お問い合わせすることにしました。

よろしく願います。

============================================================================

●お問い合わせありがとうございます。〇〇です。

●最近のトラブル
1.日本語入力
・ブログ は D3ブログを使用していますが従来できていた入力が できなくなりました。
・他の日本語入力でも同様です。
・使用エディタはFCKeditorを使用していましたが、現在xoopsデフォルトを使用しています。

FCKエディタは最新のブラウザに対応していない(*1)ので、ブラウザによって正常に動作しないことがあります。
たとえば最新のIEだとそのままではいくつかの機能が使えなかったりします。

2.ログインすると下記のコメントが発生するようになりました。

PHP5.3とのことですが、最近PHPのバージョンをあげられましたか?(*2)
XOOPS Cube Legacy2.1.xはPHP5.3に対応してなかったはずなので、
それでエラーメッセージが表示されているのだと思います。

ただどれも深刻なエラーではなく、PHP5.3以降非推奨となっている記述があることを示す警告だけのようです。
管理画面でPHPデバッグをオフにすれば表示されなくなるはずです。(*3)

上記2点ともXOOPS Cube Legacy2.1.xから XOOPS Cube Legacy2.2.xに
アップグレードすることで解消可能ですので、アップグレードをおすすめします。(*4)

============================================================================

原  因 :(*1) ブラウザの自動更新でエディタが対応していない
       (*2) サーバー側がメンテナンスで、PHPのバージョンをあげたようだ

対処法 :(*3) コメントが表示されなくなるだけ → とりあえず対処
      (*4) 根本的解決法であり、最新のxoops機能が使える!!

ところが、Xoopsのアップグレード法を検索しても難解でよく判らない

とすれば、以前、XoopsからXOOPS Cubeにアップグレードしたときのように
新規にXOOPS Cube Legacy2.2.xのページを構築したほうが楽なようだ

但し、今のページのデーターを保存しておかないといけない
以前、XoopsからXOOPS Cubeにアップグレードしたときは約1か月かかったはずだ・・・・・・

ちょっと、複数の手段を検討する

============================================================================

.
  • コメント (0)
  • トラックバック (0)
  • 閲覧 (2703)

トラックバック

トラックバックpingアドレス http://pmp.s21.coreserver.jp/xoops_cube/modules/d3blog/tb.php/464
アクセスカウンタ
今日 : 1310
昨日 : 1401
今週 : 2711
今月 : 39920
総計 : 6524409
ブログ カレンダー
« « 2017 6月 » »
28 29 30 31 1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 1
ブログアーカイブ
ログイン
ユーザー名:

パスワード:


パスワード紛失

新規登録
オンライン状況
5 人のユーザが現在オンラインです。 (5 人のユーザが D3ブログ を参照しています。)

登録ユーザ: 0
ゲスト: 5

もっと...
Google

XOOPS Cube PROJECT